summaryrefslogtreecommitdiff
path: root/src/meson.build
diff options
context:
space:
mode:
authorCarlos Garnacho <carlosg@gnome.org>2021-10-21 13:40:55 +0200
committerMarge Bot <marge-bot@gnome.org>2021-10-22 08:35:15 +0000
commit820aa18126674dcee73f47afb23ed89b57251e2d (patch)
tree1e8d01e567730c2fb0ea358ce71ab55b2412ead1 /src/meson.build
parent7c6fe21daf2d11b8c3caeee3d0a83150302ca4a2 (diff)
downloadmutter-820aa18126674dcee73f47afb23ed89b57251e2d.tar.gz
backends/native: Use rtkit to get realtime priority
Instead of using sched_setscheduler directly (and relying that we somehow got CAP_SYS_NICE), use rtkit to do this for us. Fixes: https://gitlab.gnome.org/GNOME/gnome-shell/-/issues/2284 Part-of: <https://gitlab.gnome.org/GNOME/mutter/-/merge_requests/2060>
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/meson.build b/src/meson.build
index 655b5bfca..ecf441324 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -891,6 +891,13 @@ if have_remote_desktop
mutter_built_sources += dbus_screen_cast_built_sources
endif
+dbus_rtkit_built_sources = gnome.gdbus_codegen('meta-dbus-rtkit1',
+ 'org.freedesktop.RealtimeKit1.xml',
+ interface_prefix: 'org.freedesktop.',
+ namespace: 'MetaDbus',
+)
+mutter_built_sources += dbus_rtkit_built_sources
+
wayland_protocol_server_headers = []
wayland_protocol_client_headers = []
wayland_protocol_sources = []