summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorOwen W. Taylor <otaylor@fishsoup.net>2010-10-18 15:34:08 -0400
committerOwen W. Taylor <otaylor@fishsoup.net>2010-11-18 09:47:56 -0500
commit9f4942e9a7d1fa06c6972a69eb386ff0075d3128 (patch)
tree2d6ae7b5c11d0cea3140315b1885c564af393bca /src/Makefile.am
parent982a10ac44cb09b51ea18a6515cc374a15a2f5af (diff)
downloadmutter-9f4942e9a7d1fa06c6972a69eb386ff0075d3128.tar.gz
Make shadows pretty and configurable
The current shadow code just uses a single fixed texture (the Gaussian blur of a rectangle with a fixed blur radius) for drawing all window shadows. This patch adds the ability * Implement efficient blurring of arbitrary regions by approximating a Gaussian blur with multiple box blurs. * Detect when multiple windows can use the same shadow texture by converting their shape into a size-invariant MetaWindowShape. * Add properties shadow-radius, shadow-x-offset, shadow-y-offset, shadow-opacity to allow the shadow for a window to be configured. * Add meta_window_actor_paint() and draw the shadow directly from there rather than using a child actor. * Remove TidyTextureFrame, which is no longer used https://bugzilla.gnome.org/show_bug.cgi?id=592382
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am10
1 files changed, 6 insertions, 4 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 09b90d51a..154f6add7 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -28,6 +28,8 @@ mutter_SOURCES= \
compositor/meta-plugin.c \
compositor/meta-plugin-manager.c \
compositor/meta-plugin-manager.h \
+ compositor/meta-shadow-factory.c \
+ compositor/meta-shadow-factory.h \
compositor/meta-shaped-texture.c \
compositor/meta-shaped-texture.h \
compositor/meta-texture-tower.c \
@@ -36,10 +38,10 @@ mutter_SOURCES= \
compositor/meta-window-actor-private.h \
compositor/meta-window-group.c \
compositor/meta-window-group.h \
- compositor/shadow.c \
- compositor/shadow.h \
- compositor/tidy/tidy-texture-frame.c \
- compositor/tidy/tidy-texture-frame.h \
+ compositor/meta-window-shape.c \
+ compositor/meta-window-shape.h \
+ compositor/region-utils.c \
+ compositor/region-utils.h \
include/compositor.h \
include/meta-plugin.h \
include/meta-window-actor.h \