summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorOwen W. Taylor <otaylor@fishsoup.net>2010-11-14 12:37:17 -0500
committerOwen W. Taylor <otaylor@fishsoup.net>2010-11-18 13:58:37 -0500
commit07e6c5aac2ee170819ec0ded694894d666f67174 (patch)
treef827c713233938ac3f3d7971e656851a95d7bbdd /src/Makefile.am
parent0477a3066d0633c3ebbb5c97a1f16ceed67e07a5 (diff)
downloadmutter-07e6c5aac2ee170819ec0ded694894d666f67174.tar.gz
Draw the root window background
Add code to track and draw the root window background. The advantage of doing it here as compared to in a plugin is that we can use the visiblity smarts of MetaWindowGroup to optimize out drawing the background when obscured. If handling other than tracking the _XROOTPMAP_ID property is desired in the future, more functionality like setting the background from a file or doing cross-fades can be added. The new background actor is exposed to plugins via meta_plugin_get_background_actor() similar to other exposed actors to allow cloning the background for use in other displays. The actual class is not installed for public consumption at the moment since it has no useful methods. https://bugzilla.gnome.org/show_bug.cgi?id=634833
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 5ad84f33c..ff3c30ccc 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -25,6 +25,8 @@ mutter_SOURCES= \
compositor/cogl-utils.h \
compositor/compositor.c \
compositor/compositor-private.h \
+ compositor/meta-background-actor.c \
+ compositor/meta-background-actor.h \
compositor/meta-module.c \
compositor/meta-module.h \
compositor/meta-plugin.c \