summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJonas Ådahl <jadahl@gmail.com>2015-12-15 12:51:24 +0800
committerJonas Ådahl <jadahl@gmail.com>2016-05-01 21:11:27 +0800
commit7fd585fe98b92fd7219f87b11f14bce0aaed04c0 (patch)
treed9391a1949519199ec8a08b7024686ee7664ed09 /src/Makefile.am
parent6957b5f9766f071ff76bfe02c9d7f09d6bdeec5c (diff)
downloadmutter-7fd585fe98b92fd7219f87b11f14bce0aaed04c0.tar.gz
wayland: Split out shell surface code from meta-wayland-surface.c
Move xdg_shell related functionality to a new meta-wayland-xdg-shell.c and wl_shell related functionality to a new meta-wayland-wl-shell.c, and adapt role object tree. Common functionality related to the surface being drawn as a MetaSurfaceActor was moved to a MetaWaylandSurfaceRoleActorSurface role. The subsurface role GObject is made to inherit the actor surface GObject. Shell surface hooks (configure, ping, close, popup done) were added to a MetaWaylandSurfaceRoleShellSurface GObject which inherits the surface actor role GObject. The shell surface roles (xdg_surface, xdg_popup, wl_shell_surface) are made to inherit the shell surface GObject and implement the relevant API. https://bugzilla.gnome.org/show_bug.cgi?id=757623 https://bugzilla.gnome.org/show_bug.cgi?id=763431
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 8f6a781f1..f3b15f34f 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -302,6 +302,10 @@ libmutter_la_SOURCES += \
wayland/meta-wayland-outputs.h \
wayland/meta-window-wayland.c \
wayland/meta-window-wayland.h \
+ wayland/meta-wayland-xdg-shell.c \
+ wayland/meta-wayland-xdg-shell.h \
+ wayland/meta-wayland-wl-shell.c \
+ wayland/meta-wayland-wl-shell.h \
$(NULL)
endif