summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorCarlos Garnacho <carlosg@gnome.org>2015-10-21 16:36:44 +0200
committerCarlos Garnacho <carlosg@gnome.org>2016-05-03 13:05:06 +0200
commit5849275b76015ce5c3422e52b827c3ab6e253e00 (patch)
tree7460c69f6f3e0f98dbb965817fed1de736caf56f /src/Makefile.am
parent1acfcbda6c894e42bc80c149954b365e2c2f463e (diff)
downloadmutter-5849275b76015ce5c3422e52b827c3ab6e253e00.tar.gz
wayland: Refactor MetaWaylandSurfaceRoleCursor
Move into a standalone meta-wayland-surface-role-cursor.[ch], and make generic enough to work for pointe and additional (eg. tablet) cursors. Most notably, the sprite is now kept completely internal to the cursor role, and updates are routed through the given MetaCursorRenderer (which may be the default one for the pointer, or something else). The way cursor updates after cursor surface destruction has also been reworked, the pointer will just keep track of the last cursor surface, so older surfaces being destroyed don't trigger pointer rechecks/updates.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index f3b15f34f..fca87308a 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -296,6 +296,8 @@ libmutter_la_SOURCES += \
wayland/meta-wayland-touch.h \
wayland/meta-wayland-surface.c \
wayland/meta-wayland-surface.h \
+ wayland/meta-wayland-surface-role-cursor.c \
+ wayland/meta-wayland-surface-role-cursor.h \
wayland/meta-wayland-types.h \
wayland/meta-wayland-versions.h \
wayland/meta-wayland-outputs.c \