summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorOwen W. Taylor <otaylor@fishsoup.net>2010-11-22 18:21:47 -0500
committerOwen W. Taylor <otaylor@fishsoup.net>2011-01-05 18:58:11 -0500
commit4ea00e102b6afe25e2b84f9def2f44da1b4953c6 (patch)
tree72d33cc08918788ba7fd1a4aa6f8f2ae81b62407 /src/Makefile.am
parented99d12e8b5fbc6aac720b55d0e1715d6988e111 (diff)
downloadmutter-4ea00e102b6afe25e2b84f9def2f44da1b4953c6.tar.gz
Add an "Above_Tab" pseudo-keysym
We want switching between the windows of an application to be an easily accessible operation. The convenient and memorable keybinding is the key above the tab key - but the keysym for that key isn't consistent across different keyboard layouts. Add code that figures out the key from the XKB geometry and a magic keysym name "Above_Tab" that refers to this key and switch the default binding for cycle_group to <Alt>Above_Tab. (This will have no effect for the normal case of getting the key binding from GConf until this patch is applied to Metacity as well.) https://bugzilla.gnome.org/show_bug.cgi?id=635569
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index ff3c30ccc..eedecffcf 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -51,6 +51,7 @@ mutter_SOURCES= \
include/meta-shadow-factory.h \
include/meta-window-actor.h \
include/compositor-mutter.h \
+ core/above-tab-keycode.c \
core/constraints.c \
core/constraints.h \
core/core.c \