summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorOwen W. Taylor <otaylor@fishsoup.net>2009-10-30 09:06:28 -0400
committerOwen W. Taylor <otaylor@fishsoup.net>2009-11-24 15:40:35 -0500
commit47af6a0bbf0abb4042972eab74fd25da9ba971d1 (patch)
tree86c2e5b7fe378414fcef0bd236b1ea4982d195aa /src/Makefile.am
parent988d2ffab620019573947e3915b5c94ebb225d34 (diff)
downloadmutter-47af6a0bbf0abb4042972eab74fd25da9ba971d1.tar.gz
Nice looking scaledown with mipmap emulation
Add MutterTextureTower, an abstraction for getting a image with the right level of detail for rendering at a particular scale, by manually scaling down by powers of two. This results in much better looking scaled window images when mipmaps can't be used with texture_from_pixmap (which is the typical case for current GL drivers.) When framebuffer objects are available, they are used to do the scaledown using the GPU without having to pull the data back from video memory. A software codepath is also available for the case when FBO's are not present, though performance will suffer https://bugzilla.gnome.org/show_bug.cgi?id=601032
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index d1a9fff8c..5f7683517 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -28,6 +28,8 @@ mutter_SOURCES= \
compositor/mutter-plugin-manager.c \
compositor/mutter-plugin-manager.h \
compositor/mutter-shaped-texture.c \
+ compositor/mutter-texture-tower.c \
+ compositor/mutter-texture-tower.h \
compositor/mutter-window.c \
compositor/mutter-window-private.h \
compositor/mutter-window-group.c \