summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorFlorian Müllner <fmuellner@gnome.org>2019-07-23 20:26:14 +0200
committerFlorian Müllner <fmuellner@gnome.org>2019-07-23 22:37:54 +0200
commit92868182c9b012523d1a159c98a2cfc8b7b9c8f0 (patch)
tree2e1df1b496aac01817066129adf217430384d577 /meson.build
parent08a3cbfc6cfd96f4efd8e25bc2732ad9ea7644f2 (diff)
downloadmutter-92868182c9b012523d1a159c98a2cfc8b7b9c8f0.tar.gz
build: Bump API version automatically each development cycle
Since the API version was added, we've bumped it at some point late-ish in the cycle when enough changes had accumulated (but way after the first ABI break). Automate that process by computing the API version automatically from the project version: With this commit, the new API version will be 5 for the remaining 3.33.x releases and all 3.34.x stable versions; 3.35.1 will then bump it to 6 and so forth. https://gitlab.gnome.org/GNOME/mutter/merge_requests/696
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 6 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 6b8275662..7e774c4d9 100644
--- a/meson.build
+++ b/meson.build
@@ -6,7 +6,12 @@ project('mutter', 'c',
mutter_plugin_api_version = '3'
-libmutter_api_version = '4'
+split_version = meson.project_version().split('.')
+
+# Automatically increase API version each development cycle,
+# starting with 0 in 3.23.x
+api_version = (split_version[1].to_int() - 23) / 2
+libmutter_api_version = '@0@'.format(api_version)
# generic version requirements
fribidi_req = '>= 1.0.0'