summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorOlivier Fourdan <ofourdan@redhat.com>2021-01-22 11:16:24 +0100
committerOlivier Fourdan <ofourdan@redhat.com>2021-01-22 11:40:30 +0100
commit22b926eea7171239374fee34a961b5b096675908 (patch)
tree21e84d2ec7090ba55c40bcb82d8cb76890dd5c01 /meson.build
parent26cc51a1a5345e42cd36dcf3668d5592dcc85f30 (diff)
downloadmutter-22b926eea7171239374fee34a961b5b096675908.tar.gz
xwayland: Check for listenfd option
Current Xwayland has marked the command line option "-listen" as deprecated in favor of "-listenfd". Use the pkg-config variable "have_listenfd" (if available) from Xwayland to determine if we should use that option, to avoid a deprecation warning when spawning Xwayland. Part-of: <https://gitlab.gnome.org/GNOME/mutter/-/merge_requests/1682>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build11
1 files changed, 11 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 2cf119796..88780e43c 100644
--- a/meson.build
+++ b/meson.build
@@ -391,6 +391,7 @@ if cc.has_header_symbol('sys/prctl.h', 'prctl')
endif
have_xwayland_initfd = false
+have_xwayland_listenfd = false
if have_wayland
xwayland_dep = dependency('xwayland', required: false)
@@ -434,6 +435,15 @@ if have_wayland
if (have_xwayland_initfd)
cdata.set('HAVE_XWAYLAND_INITFD', 1)
endif
+
+ # For Xwayland -listenfd usage
+ if xwayland_dep.found()
+ have_xwayland_listenfd = xwayland_dep.get_pkgconfig_variable('have_listenfd') == 'true'
+ endif
+
+ if (have_xwayland_listenfd)
+ cdata.set('HAVE_XWAYLAND_LISTENFD', 1)
+ endif
endif
have_xsetioerrorexithandler = false
@@ -518,6 +528,7 @@ output = [
' Introspection............ ' + have_introspection.to_string(),
' Profiler................. ' + have_profiler.to_string(),
' Xwayland initfd.......... ' + have_xwayland_initfd.to_string(),
+ ' Xwayland listenfd........ ' + have_xwayland_listenfd.to_string(),
' Safe X11 I/O errors...... ' + have_xsetioerrorexithandler.to_string(),
'',
' Tests:',