summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJonas Ã…dahl <jadahl@gmail.com>2019-12-06 19:05:32 +0100
committerGeorges Basile Stavracas Neto <georges.stavracas@gmail.com>2020-01-10 16:01:22 +0000
commit3e90070b88a3788f8397cb04257cb47b1d7f9642 (patch)
treef3c3fef24826509f21deb2dc0c917750db2917ea /meson.build
parentf0df07cba3ca308b47c9aefcc8112e8880fd9950 (diff)
downloadmutter-3e90070b88a3788f8397cb04257cb47b1d7f9642.tar.gz
tests/wayland: Test subsurface commits after parent was reset
Without 'wayland/surface-actor: Reset and sync subsurface state when resetting' this test would fail. This also adds a simple framework for testing lower level Wayland semantics. In contrast to the test-client and test-driver framework, which uses gtk and tests mostly window management related things, this framework is aimed to run Wayland clients made to test a particular protocol flow, thus will likely consist of manual lower level Wayland mechanics. A private protocol is added in order to help out clients do things they cannot do by themself. The protocol currently only consists of a request meant to be used for getting a callback when the actor of a given surface is eventually destroyed. This is different from the wl_surface being destroyed due to window destroy animations taking an arbitrary amount of time. It'll be used by the first test added in the next commit. https://gitlab.gnome.org/GNOME/mutter/merge_requests/961
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 700a36029..e2c116ff7 100644
--- a/meson.build
+++ b/meson.build
@@ -164,6 +164,7 @@ endif
have_wayland = get_option('wayland')
if have_wayland
wayland_server_dep = dependency('wayland-server', version: wayland_server_req)
+ wayland_client_dep = dependency('wayland-client', version: wayland_server_req)
wayland_protocols_dep = dependency('wayland-protocols',
version: wayland_protocols_req)
wayland_egl_dep = dependency('wayland-egl')