summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorAndy Holmes <andrew.g.r.holmes@gmail.com>2022-01-19 12:26:30 -0800
committerAndy Holmes <andrew.g.r.holmes@gmail.com>2022-01-20 07:48:44 -0800
commitb7ea424605d25020c532e4bcff80f3c1b35cb307 (patch)
treebab000e36ca117dd312902d5c291a06de0a69474 /meson.build
parentdea9f8bbfeb83c9aac4b968721da770e311732f6 (diff)
downloadmutter-b7ea424605d25020c532e4bcff80f3c1b35cb307.tar.gz
documentation: Generate API references with gi-docgen
gtk-doc support was taken out about six years ago, but never replaced. Add support for the newer gi-docgen, which should hopefully encourage both C and GJS users of these libraries to improve the reference. Part-of: <https://gitlab.gnome.org/GNOME/mutter/-/merge_requests/2248>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 10 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index fe57114ef..4334b8e6a 100644
--- a/meson.build
+++ b/meson.build
@@ -265,6 +265,12 @@ if have_introspection
]
endif
+have_documentation = get_option('docs')
+if have_documentation
+ gidocgen_dep = dependency('gi-docgen', version: '>= 2021.1',
+ fallback: ['gi-docgen', 'dummy_dep'])
+endif
+
have_tests = get_option('tests')
have_core_tests = false
have_cogl_tests = false
@@ -553,6 +559,9 @@ subdir('data')
subdir('src')
subdir('po')
subdir('doc/man')
+if have_documentation
+ subdir('doc/reference')
+endif
meson.add_install_script('meson/meson-postinstall.sh')
meson.add_dist_script('meson/check-version.py', meson.project_version(), 'NEWS')
@@ -579,6 +588,7 @@ summary('Wacom', have_libwacom, section: 'Options')
summary('SM', have_sm, section: 'Options')
summary('Startup notification', have_startup_notification, section: 'Options')
summary('Introspection', have_introspection, section: 'Options')
+summary('Documentation', have_documentation, section: 'Options')
summary('Profiler', have_profiler, section: 'Options')
summary('Xwayland initfd', have_xwayland_initfd, section: 'Options')
summary('Xwayland listenfd', have_xwayland_listenfd, section: 'Options')