summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJonas Ã…dahl <jadahl@gmail.com>2021-02-01 20:32:27 +0100
committerMarge Bot <marge-bot@gnome.org>2021-03-12 15:09:45 +0000
commit1940cd7fe9563c1f7ebc413adca08708630aeea6 (patch)
tree71a93093a00df9203c2d45671d35d655550975ed /meson.build
parent74ab2120fa1c79eed0d2fb872430c0b1c774b5a1 (diff)
downloadmutter-1940cd7fe9563c1f7ebc413adca08708630aeea6.tar.gz
tests: Add tests for virtual screen cast source
Tests that creating and starting a virtual screen cast monitor works, and that at least one one buffer is processed. Currently the content of the buffer isn't checked more than it can be mmap():ed. Only MemFd buffers are tested for for now, as DMA buffers would need a surfaceless EGL context to check properly. Part-of: <https://gitlab.gnome.org/GNOME/mutter/-/merge_requests/1698>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index c4bfdfe25..9dd8c5e2a 100644
--- a/meson.build
+++ b/meson.build
@@ -277,6 +277,9 @@ if have_tests
if not have_native_backend
error('Native tests require the native backend')
endif
+ if not have_remote_desktop
+ error('Native tests require remote desktop')
+ endif
endif
have_cogl_tests = get_option('cogl_tests')