summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorGeorges Basile Stavracas Neto <georges.stavracas@gmail.com>2018-12-17 13:39:54 -0200
committerGeorges Basile Stavracas Neto <georges.stavracas@gmail.com>2018-12-20 13:52:35 -0200
commit7a75692e11cca49d738e5b6b7ccaa43e5dfed6dd (patch)
tree82f92fdf2d5db70801e134db630e21a04ae00250 /meson.build
parent9bd427a74c0ffbe5f355ddcf28c3a696bf13d809 (diff)
downloadmutter-7a75692e11cca49d738e5b6b7ccaa43e5dfed6dd.tar.gz
meson: Print some configure flags
Just an additional touch after adding installed tests, outputting those flags helped not losing track of them.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build44
1 files changed, 44 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 48a1fa43d..01c985a7e 100644
--- a/meson.build
+++ b/meson.build
@@ -327,3 +327,47 @@ subdir('data')
subdir('src')
subdir('po')
subdir('doc/man')
+
+output = [
+ '',
+ '',
+ ' Mutter ' + meson.project_version(),
+ ' ===============',
+ '',
+ ' Prefix....................... ' + prefix,
+ ' libexecdir................... ' + libexecdir,
+ ' pkgdatadir................... ' + pkgdatadir,
+ '',
+ ' Rendering APIs:',
+ '',
+ ' OpenGL................... ' + have_gl.to_string(),
+ ' GLES2.................... ' + have_gles2.to_string(),
+ ' EGL...................... ' + have_egl.to_string(),
+ ' GLX...................... ' + have_glx.to_string(),
+ '',
+ ' Options:',
+ '',
+ ' Wayland.................. ' + have_wayland.to_string(),
+ ' Wayland EGLStream........ ' + have_wayland.to_string(),
+ ' Native Backend........... ' + have_native_backend.to_string(),
+ ' EGL Device............... ' + have_egl_device.to_string(),
+ ' Remote desktop........... ' + have_remote_desktop.to_string(),
+ ' gudev.................... ' + have_libgudev.to_string(),
+ ' canberra................. ' + have_libcanberra.to_string(),
+ ' Wacom.................... ' + have_libwacom.to_string(),
+ ' SM....................... ' + have_sm.to_string(),
+ ' Startup notification..... ' + have_startup_notification.to_string(),
+ ' Introspection............ ' + have_introspection.to_string(),
+ '',
+ ' Tests:',
+ '',
+ ' Enabled.................. ' + have_tests.to_string(),
+ ' Cogl tests............... ' + have_cogl_tests.to_string(),
+ ' Clutter tests............ ' + have_clutter_tests.to_string(),
+ ' Installed tests.......... ' + have_installed_tests.to_string(),
+ '',
+ ' Now type \'ninja -C ' + meson.build_root() + '\' to build ' + meson.project_name(),
+ '',
+ '',
+]
+message('\n'.join(output))