summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorFlorian Müllner <fmuellner@gnome.org>2019-01-08 22:28:18 +0100
committerFlorian Müllner <fmuellner@gnome.org>2019-01-08 22:36:20 +0100
commitd360b25b8194aa1d37d41afae08c84e5b43fb303 (patch)
tree0f5c9becac03ed622a873a4524483b309788f40f /meson.build
parent3693f6f63080cffb9893f6c9248c71f7fcc7eea3 (diff)
downloadmutter-d360b25b8194aa1d37d41afae08c84e5b43fb303.tar.gz
build: Install .pc files in correct location
If a library is provided in the positional arguments, then meson defaults to installing the .pc file in a 'pkgconfig' subdirectory in the library's install location. We want the files in the regular $libdir/pkgconfig rather than $libdir/mutter-$api/pkgconfig, so specify the location explicitly in the parameters. https://gitlab.gnome.org/GNOME/mutter/merge_requests/382
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 2ca0b4020..ce233af58 100644
--- a/meson.build
+++ b/meson.build
@@ -65,6 +65,8 @@ pkgdatadir = join_paths(datadir, pkgname)
pkglibdir = join_paths(libdir, pkgname)
pkgincludedir = join_paths(includedir, pkgname)
+pcdir = join_paths(libdir, 'pkgconfig')
+
gettext_package = meson.project_name()
localedir = join_paths(datadir, 'locale')