summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRobert Bragg <robert@linux.intel.com>2012-01-10 18:28:15 +0000
committerJasper St. Pierre <jstpierre@mecheye.net>2013-08-10 19:13:48 -0400
commitb4d108dac6171bfa526b9d65daf9a16a739c77ca (patch)
tree7bd16579066b19e99bea3e176781c3f0f171b1b1 /configure.ac
parent6585a5760bf894947b2a6ee5f105148b4713bb2c (diff)
downloadmutter-b4d108dac6171bfa526b9d65daf9a16a739c77ca.tar.gz
configure: Adds --with-xwayland-path option
This adds a --with-xwayland-path configure option that can be used to specify the absolute path of a headless X server binary supporting the wayland xserver protocol.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0cfe8def9..deecd1faa 100644
--- a/configure.ac
+++ b/configure.ac
@@ -128,6 +128,11 @@ AC_ARG_WITH([wayland-protocols],
],
[])
+AC_ARG_WITH([xwayland-path],
+ [AS_HELP_STRING([--with-xwayland-path], [Absolute path for an X Wayland server])],
+ [XWAYLAND_PATH="$withval"],
+ [XWAYLAND_PATH="$bindir/Xorg"])
+
AM_GLIB_GNU_GETTEXT
## here we get the flags we'll actually use
@@ -235,6 +240,8 @@ if test x$enable_wayland = "xyes"; then
AC_MSG_ERROR([Could not find wayland-scanner in your PATH, required for parsing wayland extension protocols]))
AC_SUBST([WAYLAND_SCANNER])
+ AC_SUBST(XWAYLAND_PATH)
+
MUTTER_PC_MODULES="$MUTTER_PC_MODULES wayland-server clutter-wayland-compositor-1.0"
AC_DEFINE(HAVE_WAYLAND, , [Building with Wayland support])
have_wayland=yes