summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorOlivier Fourdan <ofourdan@redhat.com>2017-09-05 18:53:41 +0200
committerOlivier Fourdan <ofourdan@redhat.com>2017-12-15 14:18:14 +0100
commitdb32047a5dd631812a94be72568504ba64a06b43 (patch)
tree52c3ddacea2d0a993ca95028336f35d6be5a9a74 /configure.ac
parentb505eb261ebe762f1dcc5ab8b55b3ab0932e86be (diff)
downloadmutter-db32047a5dd631812a94be72568504ba64a06b43.tar.gz
wayland: Add xdg-output support
The xdg-output protocol aims at describing outputs in way which is more in line with the concept of an output on desktop oriented systems. For now it just features the position and logical size which describe the output position and size in the global compositor space. This is however much useful for Xwayland to advertise the output size and position to X11 clients which need this to configure their surfaces in the global compositor space as the compositor may apply a different scale from what is advertised by the output scaling property (to achieve fractional scaling, for example). This was added in wayland-protocols 1.10. https://bugzilla.gnome.org/show_bug.cgi?id=787363
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d8fe6d697..69548673d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -306,7 +306,7 @@ AS_IF([test "$have_wayland" = "yes"], [
AC_SUBST([WAYLAND_SCANNER])
AC_DEFINE([HAVE_WAYLAND],[1],[Define if you want to enable Wayland support])
- PKG_CHECK_MODULES(WAYLAND_PROTOCOLS, [wayland-protocols >= 1.9],
+ PKG_CHECK_MODULES(WAYLAND_PROTOCOLS, [wayland-protocols >= 1.10],
[ac_wayland_protocols_pkgdatadir=`$PKG_CONFIG --variable=pkgdatadir wayland-protocols`])
AC_SUBST(WAYLAND_PROTOCOLS_DATADIR, $ac_wayland_protocols_pkgdatadir)
])