summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorFlorian Müllner <fmuellner@gnome.org>2018-04-26 16:07:32 +0200
committerFlorian Müllner <fmuellner@gnome.org>2018-05-07 19:50:20 +0200
commit82564772dc27c9b86270e5a694b04945d3f5e3a1 (patch)
tree68cad9fe318b62cb088eb29218e29cf6df1f1e8e /configure.ac
parent33c2a38ff7ce22f5e6f202ba1a3289eff61787fe (diff)
downloadmutter-82564772dc27c9b86270e5a694b04945d3f5e3a1.tar.gz
build: Don't fail immediately when logind is missingwip/fmuellner/optional-logind
We require logind for the native backend, but the backend itself is optional. However since commit 06c357d78, we will always throw an error if neither logind nor elogind are available, even when the backend is disabled. As we still support "auto" - that is, whether the native backend is enabled depends on whether its dependencies are available - the easiest option is to make sure we always include either elogind or libsystemd in the dependency check rather than erring out explicitly if neither is found. https://gitlab.gnome.org/GNOME/mutter/merge_requests/96
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 1 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 3f8dec07c..f6b5f46be 100644
--- a/configure.ac
+++ b/configure.ac
@@ -270,13 +270,10 @@ fi
PKG_CHECK_MODULES(SYSTEMD, [libsystemd], [have_systemd=yes], [have_systemd=no])
-if test x$have_systemd = xyes; then
+if test x$have_systemd = xyes -o -z "$logind_provider"; then
logind_provider="libsystemd"
fi
-AS_IF([test -z "$logind_provider"],
- AC_MSG_ERROR([Could not find either systemd or elogind as logind provider])])
-
MUTTER_NATIVE_BACKEND_MODULES="libdrm $logind_provider libinput >= 1.4 gudev-1.0 gbm >= 10.3"
AC_ARG_ENABLE(native-backend,