summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorFlorian Müllner <fmuellner@gnome.org>2017-10-05 21:38:25 +0200
committerFlorian Müllner <fmuellner@gnome.org>2017-10-05 22:11:14 +0200
commit18c41aefc982864225ea993a0d0213e22e07e62e (patch)
tree79e709020ef7909c26f3536dbb62842b0c17316a /configure.ac
parent32917f1922c3a727f747477caad1f9611582fe59 (diff)
downloadmutter-18c41aefc982864225ea993a0d0213e22e07e62e.tar.gz
build: Fetch pipewire micro version
Pipewire doesn't export its version defines, so the API checks added in commit f0c6c4eb1fa2b21e38 effectively disable screencasting, whoops. Breaking changes like this should disappear once the library stabilizes, so simply define the version ourselves instead of writing a "proper" test with AC_COMPILE_IFELSE() ... https://bugzilla.gnome.org/show_bug.cgi?id=788572
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 89c15e23b..a5870e6ab 100644
--- a/configure.ac
+++ b/configure.ac
@@ -245,6 +245,10 @@ AC_ARG_ENABLE(remote-desktop,
)
AS_IF([test "$enable_remote_desktop" = "yes"], [
MUTTER_PC_MODULES="$MUTTER_PC_MODULES libpipewire-0.1 >= 0.1.4"
+ PKG_CHECK_EXISTS([libpipewire-0.1], [
+ pw_micro=`$PKG_CONFIG --modversion libpipewire-0.1 | cut -d. -f3`
+ AC_DEFINE_UNQUOTED([PIPEWIRE_VERSION_MICRO],[$pw_micro], [Pipewire micro version used])
+ ])
AC_DEFINE([HAVE_REMOTE_DESKTOP],[1], [Defined if screen cast and remote desktop support is enabled])
])
AM_CONDITIONAL([HAVE_REMOTE_DESKTOP],[test "$enable_remote_desktop" = "yes"])