summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGiovanni Campagna <gcampagn@redhat.com>2013-08-16 13:49:03 +0200
committerGiovanni Campagna <gcampagn@redhat.com>2013-08-26 15:00:29 +0200
commit91cdfab495606a5c541f8ad090ad0b9369380a40 (patch)
tree061d19f47ea0549997935892fe4b10256100f03b /configure.ac
parent1617323dca15d793591e454a39f6b2aa8f900ed0 (diff)
downloadmutter-91cdfab495606a5c541f8ad090ad0b9369380a40.tar.gz
build: make wayland support unconditional
In the wayland branch of mutter, we want to build a wayland version of the mutter libraries, and that's much easier if we just build wayland support unconditionally. The define is kept to avoid a huge diff, but should be removed in a later patch. Also, wayland support can still be disable at runtime, by launching mutter without the --nested switch. https://bugzilla.gnome.org/show_bug.cgi?id=705497
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac38
1 files changed, 9 insertions, 29 deletions
diff --git a/configure.ac b/configure.ac
index fd3c45579..dfaf23f02 100644
--- a/configure.ac
+++ b/configure.ac
@@ -113,11 +113,6 @@ AC_ARG_ENABLE(shape,
[disable mutter's use of the shaped window extension]),,
enable_shape=auto)
-AC_ARG_ENABLE(wayland,
- AC_HELP_STRING([--enable-wayland],
- [Enable support for running as a hybrid X and Wayland compositor]),,
- enable_wayland=no)
-
## Wayland support requires the xserver.xml protocol extension found in the weston
## repository but since there aren't currently established conventions for
## installing and discovering these we simply require a location to be given
@@ -216,29 +211,16 @@ if test x$have_xcursor = xyes; then
AC_DEFINE(HAVE_XCURSOR, , [Building with Xcursor support])
fi
-have_wayland=no
-if test x$enable_wayland = "xyes"; then
- WAYLAND_VERSION=0.1
- AC_MSG_CHECKING([Wayland >= $WAYLAND_VERSION])
- if ! $PKG_CONFIG --atleast-version $WAYLAND_VERSION wayland-server; then
- AC_MSG_ERROR([wayland support enabled but no suitable wayland-server package found])
- fi
- AC_MSG_RESULT(yes)
-
- AC_PATH_PROG([WAYLAND_SCANNER],[wayland-scanner],[no])
- AS_IF([test "x$WAYLAND_SCANNER" = "xno"],
- AC_MSG_ERROR([Could not find wayland-scanner in your PATH, required for parsing wayland extension protocols]))
- AC_SUBST([WAYLAND_SCANNER])
+# We always build with wayland enabled
+AC_DEFINE(HAVE_WAYLAND, , [Building with Wayland support])
- AC_SUBST(XWAYLAND_PATH)
-
- MUTTER_PC_MODULES="$MUTTER_PC_MODULES wayland-server"
- AC_DEFINE(HAVE_WAYLAND, , [Building with Wayland support])
- have_wayland=yes
-fi
-
-AM_CONDITIONAL(HAVE_WAYLAND, test x$have_wayland = "xyes")
+AC_PATH_PROG([WAYLAND_SCANNER],[wayland-scanner],[no])
+AS_IF([test "x$WAYLAND_SCANNER" = "xno"],
+ AC_MSG_ERROR([Could not find wayland-scanner in your PATH, required for parsing wayland extension protocols]))
+AC_SUBST([WAYLAND_SCANNER])
+AC_SUBST(XWAYLAND_PATH)
+MUTTER_PC_MODULES="$MUTTER_PC_MODULES wayland-server"
PKG_CHECK_MODULES(MUTTER, $MUTTER_PC_MODULES)
PKG_CHECK_EXISTS([xi >= 1.6.99.1],
@@ -496,14 +478,12 @@ fi
dnl ==========================================================================
echo "
-mutter-$VERSION
+mutter-wayland-$VERSION
prefix: ${prefix}
source code location: ${srcdir}
compiler: ${CC}
- Wayland: ${have_wayland}
-
Startup notification: ${have_startup_notification}
libcanberra: ${have_libcanberra}
Introspection: ${found_introspection}