summaryrefslogtreecommitdiff
path: root/clutter/Makefile.am
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gnome.org>2014-03-17 18:45:56 +0000
committerEmmanuele Bassi <ebassi@gnome.org>2014-03-17 19:26:49 +0000
commit386be83f249f81bdb95bdccda473f8f1e9cad2c2 (patch)
treef0a280cb8f5d16db4ce958b04f54ebac7aca32a7 /clutter/Makefile.am
parent5c4c2aa52f209758c3f6533ebcaeebf6b80fa029 (diff)
downloadmutter-386be83f249f81bdb95bdccda473f8f1e9cad2c2.tar.gz
New visibility handling in Clutter
Instead of listing every public symbol inside an ancillary file, we can use compiler annotations. This scheme is also used by GLib and GTK+. The symbols file is left in tree until the Visual Studio rules are fixed, but it's not used any more during distcheck. I double-checked that the exposed ABI is the same before and after this change, except for symbols that were never meant to be public in the first place, and that escaped our attention when we generated the first version of the symbols file.
Diffstat (limited to 'clutter/Makefile.am')
-rw-r--r--clutter/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/clutter/Makefile.am b/clutter/Makefile.am
index fbea8920f..7a67ea57a 100644
--- a/clutter/Makefile.am
+++ b/clutter/Makefile.am
@@ -29,6 +29,7 @@ AM_CPPFLAGS = \
$(CLUTTER_DEPRECATED_CFLAGS) \
$(CLUTTER_DEBUG_CFLAGS) \
$(CLUTTER_PROFILE_CFLAGS) \
+ $(CLUTTER_HIDDEN_VISIBILITY_CFLAGS) \
$(NULL)
AM_CFLAGS = $(CLUTTER_CFLAGS) $(MAINTAINER_CFLAGS)
@@ -850,7 +851,6 @@ libclutter_@CLUTTER_API_VERSION@_la_LDFLAGS = \
$(CLUTTER_LINK_FLAGS) \
$(CLUTTER_LT_LDFLAGS) \
-export-dynamic \
- -export-symbols-regex "^(clutter|cally).*" \
-rpath $(libdir) \
$(win32_resources_ldflag) \
$(NULL)