summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRobert Bragg <robert@linux.intel.com>2012-03-24 01:41:48 +0000
committerRobert Bragg <robert@linux.intel.com>2012-08-06 14:27:42 +0100
commit10340a5495b860f64f4dd8f9ed5b9928ae39b781 (patch)
tree3ded24ebf4e88d114e0b5a6c2d6e726bf76de959 /Makefile.am
parent010d16f6479c90b66b7f90ab0341575b41555fca (diff)
downloadmutter-10340a5495b860f64f4dd8f9ed5b9928ae39b781.tar.gz
Adds libcogl-gles2 frontend GLES2 api
This adds a library that can be used instead of libGLESv2.so to provide symbols for the GLES 2.0 api. This can be used for convenience when using the cogl_gles2_context_ api since you don't need to manually go through a CoglGLES2Vtable when calling the gles2 api so it should be easier to port existing gles2 code to integrate with Cogl. Reviewed-by: Neil Roberts <neil@linux.intel.com> (cherry picked from commit 80d7599a2acefca7d01d8d7de9df524278ef72c5)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index bbb16ae3a..c998738be 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4,6 +4,10 @@ if BUILD_COGL_PANGO
SUBDIRS += cogl-pango
endif
+if BUILD_COGL_GLES2
+SUBDIRS += cogl-gles2
+endif
+
SUBDIRS += examples doc po build
ACLOCAL_AMFLAGS = -I build/autotools ${ACLOCAL_FLAGS}