summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNeil Roberts <neil@linux.intel.com>2012-01-18 23:03:23 +0000
committerJasper St. Pierre <jstpierre@mecheye.net>2013-08-10 19:13:49 -0400
commita5585327dc35f0aace52a827dcdb7450eee74bf9 (patch)
tree2d0011a94e08a9136e6cf22c3affbacaa32450e4 /Makefile.am
parent268ebb1b18c7dccb292c9cab4e5aea574c2e5f59 (diff)
downloadmutter-a5585327dc35f0aace52a827dcdb7450eee74bf9.tar.gz
wayland: Add an actor for the cursor
When running Mutter under Cogl's KMS backend no cursor will be provided so instead this makes it so the cursor will be painted as a CoglTexture that gets moved in response to mouse motion events. The painting is done in a subclass of ClutterStage so that we can guarantee that the cursor will be painted on top of everything else. This patch adds support for the set_cursor method on the pointer interface so that clients can change the cursor image. The set_pointer method sets a surface and a hotspot position to use for the cursor image. The surface's buffer is converted to a CoglTexture and attached to a pipeline to paint directly via Cogl. If a new buffer is attached to the surface the image will be updated. The cursor reverts back to the default image whenever to the pointer focus is moved off of any surface. The image for the pointer is taken from X. It gets installed into a fixed data location for mutter.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 979ba2573..18afe05c7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,5 +1,5 @@
-SUBDIRS=src protocol po doc
+SUBDIRS=src protocol data po doc
EXTRA_DIST = HACKING MAINTAINERS rationales.txt