summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorvlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2002-04-03 12:12:45 +0000
committervlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2002-04-03 12:12:45 +0000
commit74f94f1b3ed6f0d98acfb8f8b500f3fb9690ea55 (patch)
treee03a3fb2a7b404933dbd85654ed9b8ecf56fb7e2 /configure.in
parentc9abfc172490926fe1c147aebe62630a6e94ae65 (diff)
downloadmpfr-74f94f1b3ed6f0d98acfb8f8b500f3fb9690ea55.tar.gz
Re-fix.
git-svn-id: svn://scm.gforge.inria.fr/svn/mpfr/trunk@1803 280ebfd0-de03-0410-8827-d642c229c3f4
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index bfaead467..cc22a6c17 100644
--- a/configure.in
+++ b/configure.in
@@ -72,7 +72,8 @@ AC_TRY_COMPILE([
#include "longlong.h"
], , AC_MSG_RESULT(yes),
[AC_MSG_RESULT(no)
- AC_MSG_ERROR(gmp.h or gmp-impl.h or config.h or gmp-mparam.h or longlong.h may be missing ${with_gmp_include:+in $with_gmp_include})]
+ AC_MSG_ERROR([gmp.h or gmp-impl.h or config.h or gmp-mparam.h or
+longlong.h may be missing ${with_gmp_include:+in $with_gmp_include}])]
)
dnl Check BITS_PER_MP_LIMB and BYTES_PER_MP_LIMB
@@ -88,12 +89,11 @@ int main()
}
], AC_MSG_RESULT(yes),
[AC_MSG_RESULT(no)
-dnl do not use the AC_MSG_ERROR macro because of message truncation...
-{ echo "configure: error: BITS_PER_MP_LIMB and/or BYTES_PER_MP_LIMB are incorrect.
+ AC_MSG_ERROR([BITS_PER_MP_LIMB and/or BYTES_PER_MP_LIMB are incorrect.
You probably need to change some of the GMP or MPFR compile options:
MPFR doesn't currently do as many architecture checks as GMP, so the
-default target architecture may be different, hence the error." 1>&2
- exit 1; }])
+default target architecture may be different, hence the error.])]
+)
dnl Check random functions
AC_MSG_CHECKING(for rand48 functions)