summaryrefslogtreecommitdiff
path: root/skeletonmm/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'skeletonmm/meson.build')
-rw-r--r--skeletonmm/meson.build8
1 files changed, 5 insertions, 3 deletions
diff --git a/skeletonmm/meson.build b/skeletonmm/meson.build
index 7190ada..982a4b1 100644
--- a/skeletonmm/meson.build
+++ b/skeletonmm/meson.build
@@ -161,21 +161,23 @@ endif
warning_flags = cpp_compiler.get_supported_arguments(warning_flags)
add_project_arguments(warning_flags, language: 'cpp')
+# add_dist_script() is not allowed in a subproject if meson.version() < 0.58.0.
+can_add_dist_script = not meson.is_subproject() or meson.version().version_compare('>= 0.58.0')
+
subdir('tools/extra_defs_gen')
subdir('skeleton')
subdir('examples')
subdir('tests')
subdir('doc/reference')
-if not meson.is_subproject()
+if can_add_dist_script
# Add a ChangeLog file to the distribution directory.
- # (add_dist_script() is not allowed in a subproject)
meson.add_dist_script(
python3.path(), dist_changelog,
project_source_root,
)
# Add build scripts to the distribution directory, and delete .gitignore
- # files and an empty $MESON_DIST_ROOT/build/ directory.
+ # files and an empty $MESON_PROJECT_DIST_ROOT/build/ directory.
meson.add_dist_script(
python3.path(), dist_build_scripts,
project_source_root,