summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py5
1 files changed, 5 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index b061d6a..48d191c 100644
--- a/setup.py
+++ b/setup.py
@@ -48,6 +48,11 @@ class ve_build_ext(build_ext):
build_ext.build_extension(self, ext)
except ext_errors:
raise BuildFailed()
+ except ValueError, err:
+ # may happen on Win 64 bit, see Python issue7511
+ if "'path'" in str(err):
+ raise BuildFailed()
+ raise
def echo(msg=''):