summaryrefslogtreecommitdiff
path: root/unittest/mysys/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'unittest/mysys/CMakeLists.txt')
-rw-r--r--unittest/mysys/CMakeLists.txt36
1 files changed, 36 insertions, 0 deletions
diff --git a/unittest/mysys/CMakeLists.txt b/unittest/mysys/CMakeLists.txt
new file mode 100644
index 00000000000..94eb3159693
--- /dev/null
+++ b/unittest/mysys/CMakeLists.txt
@@ -0,0 +1,36 @@
+# Copyright (C) 2007 MySQL AB, 2009 Sun Microsystems,Inc
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; version 2 of the License.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
+
+INCLUDE_DIRECTORIES(${CMAKE_SOURCE_DIR}/include
+ ${CMAKE_SOURCE_DIR}/sql
+ ${CMAKE_SOURCE_DIR}/regex
+ ${CMAKE_SOURCE_DIR}/extra/yassl/include
+ ${CMAKE_SOURCE_DIR}/unittest/mytap)
+
+
+MACRO (MY_ADD_TEST name)
+ ADD_EXECUTABLE(${name}-t ${name}-t.c)
+ TARGET_LINK_LIBRARIES(${name}-t mytap mysys)
+ ADD_TEST(${name} ${name}-t)
+ENDMACRO()
+
+
+FOREACH(testname bitmap base64 my_vsnprintf)
+ MY_ADD_TEST(${testname})
+ENDFOREACH()
+IF(NOT WIN32)
+ # does not work on Windows in 5.x codebase
+ MY_ADD_TEST(my_atomic)
+ENDIF()