summaryrefslogtreecommitdiff
path: root/unittest/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'unittest/Makefile.am')
-rw-r--r--unittest/Makefile.am10
1 files changed, 6 insertions, 4 deletions
diff --git a/unittest/Makefile.am b/unittest/Makefile.am
index 3e7fc37e4f6..8943e58170d 100644
--- a/unittest/Makefile.am
+++ b/unittest/Makefile.am
@@ -1,11 +1,13 @@
SUBDIRS = mytap . mysys examples
-.PHONY: mytap mysys examples test
-
noinst_SCRIPTS = unit
-test: mytap mysys examples
- ./unit run $^
+unittests = mysys examples
+
+.PHONY: all mytap mysys examples test
+
+test: unit all
+ @./unit run $(unittests)
mytap:
cd mytap && $(MAKE)