summaryrefslogtreecommitdiff
path: root/storage/ndb/src/kernel/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'storage/ndb/src/kernel/Makefile.am')
-rw-r--r--storage/ndb/src/kernel/Makefile.am21
1 files changed, 18 insertions, 3 deletions
diff --git a/storage/ndb/src/kernel/Makefile.am b/storage/ndb/src/kernel/Makefile.am
index 610dc63d51e..343d5eeab6d 100644
--- a/storage/ndb/src/kernel/Makefile.am
+++ b/storage/ndb/src/kernel/Makefile.am
@@ -1,3 +1,18 @@
+# Copyright (C) 2004-2006 MySQL AB
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; version 2 of the License.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
+
SUBDIRS = vm error blocks
include $(top_srcdir)/storage/ndb/config/common.mk.am
@@ -42,9 +57,6 @@ LDADD += \
$(top_builddir)/mysys/libmysys.a \
$(top_builddir)/strings/libmystrings.a @NDB_SCI_LIBS@
-# Don't update the files from bitkeeper
-%::SCCS/s.%
-
windoze-dsp: ndbd.dsp
storage/ndbd.dsp: Makefile \
@@ -58,3 +70,6 @@ storage/ndbd.dsp: Makefile \
@$(top_srcdir)/storage/ndb/config/win-includes $@ $(INCLUDES)
@$(top_srcdir)/storage/ndb/config/win-sources $@ $(ndbd_SOURCES)
@$(top_srcdir)/storage/ndb/config/win-libraries $@ LINK $(LDADD)
+
+# Don't update the files from bitkeeper
+%::SCCS/s.%