summaryrefslogtreecommitdiff
path: root/storage/innobase/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'storage/innobase/CMakeLists.txt')
-rw-r--r--storage/innobase/CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/storage/innobase/CMakeLists.txt b/storage/innobase/CMakeLists.txt
index aee68b8460d..9313f5c33b8 100644
--- a/storage/innobase/CMakeLists.txt
+++ b/storage/innobase/CMakeLists.txt
@@ -1,6 +1,6 @@
# Copyright (c) 2006, 2017, Oracle and/or its affiliates. All rights reserved.
-# Copyright (c) 2014, 2021, MariaDB Corporation.
+# Copyright (c) 2014, 2022, MariaDB Corporation.
#
# This program is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -173,7 +173,6 @@ SET(INNOBASE_SOURCES
include/lock0types.h
include/log0crypt.h
include/log0log.h
- include/log0log.inl
include/log0recv.h
include/log0types.h
include/mach0data.h
@@ -204,7 +203,6 @@ SET(INNOBASE_SOURCES
include/que0types.h
include/read0types.h
include/rem0cmp.h
- include/rem0cmp.inl
include/rem0rec.h
include/rem0rec.inl
include/rem0types.h
@@ -338,7 +336,9 @@ OPTION(WITH_PMEM "Support redo log in persistent memory" OFF)
FIND_PACKAGE(PMEM)
IF(PMEM_FOUND)
INCLUDE_DIRECTORIES(${PMEM_INCLUDES})
- ADD_COMPILE_FLAGS(log/log0log.cc COMPILE_FLAGS "-DHAVE_PMEM")
+ ADD_COMPILE_FLAGS(log/log0log.cc log/log0recv.cc
+ buf/buf0flu.cc mtr/mtr0mtr.cc trx/trx0trx.cc srv/srv0start.cc
+ COMPILE_FLAGS "-DHAVE_PMEM")
SET(PMEM_LIBRARY ${PMEM_LIBRARIES})
ELSE()
IF(WITH_PMEM)