summaryrefslogtreecommitdiff
path: root/storage/csv/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'storage/csv/CMakeLists.txt')
-rw-r--r--storage/csv/CMakeLists.txt22
1 files changed, 22 insertions, 0 deletions
diff --git a/storage/csv/CMakeLists.txt b/storage/csv/CMakeLists.txt
new file mode 100644
index 00000000000..1f4b3b1c220
--- /dev/null
+++ b/storage/csv/CMakeLists.txt
@@ -0,0 +1,22 @@
+# Copyright (c) 2006-2008 MySQL AB, 2009 Sun Microsystems, Inc.
+# Use is subject to license terms.
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; version 2 of the License.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
+
+SET(CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG} -DSAFEMALLOC -DSAFE_MUTEX")
+SET(CMAKE_C_FLAGS_DEBUG "${CMAKE_C_FLAGS_DEBUG} -DSAFEMALLOC -DSAFE_MUTEX")
+
+INCLUDE("${PROJECT_SOURCE_DIR}/storage/mysql_storage_engine.cmake")
+SET(CSV_SOURCES ha_tina.cc ha_tina.h transparent_file.cc transparent_file.h)
+MYSQL_STORAGE_ENGINE(CSV) \ No newline at end of file