summaryrefslogtreecommitdiff
path: root/scripts/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'scripts/Makefile.am')
-rw-r--r--scripts/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
index 471a23f0a73..fed96490397 100644
--- a/scripts/Makefile.am
+++ b/scripts/Makefile.am
@@ -90,6 +90,9 @@ CLEANFILES = @server_scripts@ \
mysql_tableinfo \
mysqld_multi
+# Default same as 'pkgdatadir', but we can override it
+pkgsuppdir = $(datadir)/@PACKAGE@
+
# mysqlbug should be distributed built so that people can report build
# failures with it.
DISTCLEANFILES = $(BUILT_SOURCES) mysqlbug
@@ -134,6 +137,7 @@ SUFFIXES = .sh
-e 's!@''pkglibdir''@!$(pkglibdir)!g' \
-e 's!@''pkgincludedir''@!$(pkgincludedir)!g' \
-e 's!@''pkgdatadir''@!$(pkgdatadir)!g' \
+ -e 's!@''pkgsuppdir''@!$(pkgsuppdir)!g' \
-e 's!@''sysconfdir''@!$(sysconfdir)!g' \
-e 's!@''mandir''@!$(mandir)!g' \
-e 's!@''infodir''@!$(infodir)!g' \