summaryrefslogtreecommitdiff
path: root/plugin/provider_bzip2/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'plugin/provider_bzip2/CMakeLists.txt')
-rw-r--r--plugin/provider_bzip2/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/plugin/provider_bzip2/CMakeLists.txt b/plugin/provider_bzip2/CMakeLists.txt
new file mode 100644
index 00000000000..e2ac4592b1b
--- /dev/null
+++ b/plugin/provider_bzip2/CMakeLists.txt
@@ -0,0 +1,15 @@
+FIND_PACKAGE(BZip2)
+
+SET(CPACK_RPM_provider-bzip2_PACKAGE_SUMMARY "BZip2 compression support in the server and storage engines" PARENT_SCOPE)
+SET(CPACK_RPM_provider-bzip2_PACKAGE_DESCRIPTION "BZip2 compression support in the server and storage engines" PARENT_SCOPE)
+
+IF (BZIP2_FOUND)
+ GET_PROPERTY(dirs DIRECTORY PROPERTY INCLUDE_DIRECTORIES)
+ LIST(REMOVE_ITEM dirs ${CMAKE_SOURCE_DIR}/include/providers)
+ SET_PROPERTY(DIRECTORY PROPERTY INCLUDE_DIRECTORIES "${dirs}")
+
+ INCLUDE_DIRECTORIES(${BZIP2_INCLUDE_DIRS})
+
+ MYSQL_ADD_PLUGIN(provider_bzip2 plugin.c COMPONENT provider-bzip2
+ LINK_LIBRARIES ${BZIP2_LIBRARIES} CONFIG provider_bzip2.cnf)
+ENDIF()