summaryrefslogtreecommitdiff
path: root/plugin/auth_gssapi/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'plugin/auth_gssapi/CMakeLists.txt')
-rw-r--r--plugin/auth_gssapi/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/plugin/auth_gssapi/CMakeLists.txt b/plugin/auth_gssapi/CMakeLists.txt
index 1bf727ddf2e..8c82d335ab2 100644
--- a/plugin/auth_gssapi/CMakeLists.txt
+++ b/plugin/auth_gssapi/CMakeLists.txt
@@ -38,6 +38,7 @@ ELSE()
IF(HAVE_KRB5_XFREE)
ADD_DEFINITIONS(-DHAVE_KRB5_XFREE=1)
ENDIF()
+ MY_CHECK_AND_SET_COMPILER_FLAG(-Wl,--as-needed)
ELSE()
# Can't build plugin