summaryrefslogtreecommitdiff
path: root/include/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'include/Makefile.am')
-rw-r--r--include/Makefile.am16
1 files changed, 4 insertions, 12 deletions
diff --git a/include/Makefile.am b/include/Makefile.am
index 0c845900a4f..3fa7b04d69a 100644
--- a/include/Makefile.am
+++ b/include/Makefile.am
@@ -38,23 +38,15 @@ SUPERCLEANFILES = mysql_version.h my_config.h
# Some include files that may be moved and patched by configure
DISTCLEANFILES = sched.h $(SUPERCLEANFILES)
-clean:
+clean-local:
$(RM) -fr readline
-distclean:
+distclean-local:
$(RM) -fr readline
-all-local: my_config.h
-
-# Since we include my_config.h it better exist from the beginning
-link_sources:
- $(CP) ../config.h my_config.h
- -$(RM) -fr readline
- @readline_h_ln_cmd@
-
-# Keep automake happy
-
my_config.h: ../config.h
$(CP) ../config.h my_config.h
+
+link_sources:
-$(RM) -fr readline
@readline_h_ln_cmd@