summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index f3e93afb72e..d6acef071a6 100644
--- a/configure.in
+++ b/configure.in
@@ -2811,6 +2811,24 @@ AC_DEFINE_UNQUOTED([MYSQL_DEFAULT_CHARSET_NAME], ["$default_charset"],
AC_DEFINE_UNQUOTED([MYSQL_DEFAULT_COLLATION_NAME], ["$default_collation"],
[Define the default charset name])
+
+# Shall we build the UCA-based Unicode collations
+AC_ARG_WITH(uca,
+ [ --without-uca Skip building of the national Unicode collations.],
+ [with_uca=$withval],
+ [with_uca=yes]
+)
+
+AC_MSG_CHECKING([whether to compile national Unicode collations])
+
+if test "$with_uca" = "yes"
+then
+ AC_MSG_RESULT(yes)
+ AC_DEFINE([HAVE_UCA_COLLATIONS], [1], [national Unicode collations])
+else
+ AC_MSG_RESULT(no)
+fi
+
MYSQL_CHECK_ISAM
MYSQL_CHECK_BDB
MYSQL_CHECK_INNODB