summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am19
1 files changed, 15 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index d6245ac95d7..cb8f09023d6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -109,15 +109,26 @@ MYSQL_TEST_RUN_ARGS = --manager-port=$(MYSQL_TEST_MANAGER_PORT) \
--master_port=$(MYSQL_TEST_MASTER_PORT) \
--slave_port=$(MYSQL_TEST_SLAVE_PORT) \
--ndbcluster_port=$(MYSQL_TEST_NDB_PORT)
+
test:
cd mysql-test ; \
- ./mysql-test-run.pl $(MYSQL_TEST_RUN_ARGS) && \
- ./mysql-test-run.pl --ps-protocol $(MYSQL_TEST_RUN_ARGS)
+ ./mysql-test-run $(MYSQL_TEST_RUN_ARGS) && \
+ ./mysql-test-run $(MYSQL_TEST_RUN_ARGS) --ps-protocol
test-force:
cd mysql-test ; \
- ./mysql-test-run --force $(MYSQL_TEST_RUN_ARGS) ; \
- ./mysql-test-run --ps-protocol --force $(MYSQL_TEST_RUN_ARGS)
+ ./mysql-test-run $(MYSQL_TEST_RUN_ARGS) --force ; \
+ ./mysql-test-run $(MYSQL_TEST_RUN_ARGS) --ps-protocol --force
+
+test-pl:
+ cd mysql-test ; \
+ ./mysql-test-run.pl $(MYSQL_TEST_RUN_ARGS) && \
+ ./mysql-test-run.pl $(MYSQL_TEST_RUN_ARGS) --ps-protocol
+
+test-force-pl:
+ cd mysql-test ; \
+ ./mysql-test-run.pl $(MYSQL_TEST_RUN_ARGS) --force ; \
+ ./mysql-test-run.pl $(MYSQL_TEST_RUN_ARGS) --ps-protocol --force
# Don't update the files from bitkeeper
%::SCCS/s.%