summaryrefslogtreecommitdiff
path: root/vio/Makefile.am
diff options
context:
space:
mode:
authorunknown <msvensson@neptunus.(none)>2005-10-18 15:43:59 +0200
committerunknown <msvensson@neptunus.(none)>2005-10-18 15:43:59 +0200
commit69585b215b6ca854f9a0757787242df30193946f (patch)
tree710b8c5ba5604cf18f75c3f2e6e10ccc0fcb9003 /vio/Makefile.am
parentb50eb4cd42d2d5073afb2af5af8b19c825a9cca1 (diff)
downloadmariadb-git-69585b215b6ca854f9a0757787242df30193946f.tar.gz
Bug #12985 Do-mysqlclient-test: Can't find -lyassl when linking
- Use yassl_includes and yassl_libs instead of openssl_includes and openssl_libs to avoid that mysql_config returns that libyassl and libtaocrypt are needed for linking. client/Makefile.am: Add yassl_includes config/ac-macros/yassl.m4: Use own variables for yassl, don't intrude on openssl configure.in: Add yassl_libs to lib_DEPENDENCIES and CLIENT_LIBS libmysql/Makefile.am: Add yassl_includes libmysql_r/Makefile.am: Add yassl_libs and yassl_includes libmysqld/Makefile.am: Add yassl_includes server-tools/instance-manager/Makefile.am: Add yassl includes and lib sql/Makefile.am: Add yassl includes and libe vio/Makefile.am: Add yassl includes and libe
Diffstat (limited to 'vio/Makefile.am')
-rw-r--r--vio/Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/vio/Makefile.am b/vio/Makefile.am
index 0d4f052b30a..544639139de 100644
--- a/vio/Makefile.am
+++ b/vio/Makefile.am
@@ -20,23 +20,23 @@ else
yassl_dummy_link_fix=
endif
INCLUDES= -I$(top_builddir)/include -I$(top_srcdir)/include \
- $(openssl_includes)
-LDADD= @CLIENT_EXTRA_LDFLAGS@ $(openssl_libs)
+ $(openssl_includes) $(yassl_includes)
+LDADD= @CLIENT_EXTRA_LDFLAGS@ $(openssl_libs) $(yassl_libs)
pkglib_LIBRARIES= libvio.a
noinst_PROGRAMS = test-ssl test-sslserver test-sslclient
noinst_HEADERS= vio_priv.h
test_ssl_SOURCES= test-ssl.c $(yassl_dummy_link_fix)
test_ssl_LDADD= @CLIENT_EXTRA_LDFLAGS@ ../dbug/libdbug.a libvio.a \
../mysys/libmysys.a ../strings/libmystrings.a \
- $(openssl_libs)
+ $(openssl_libs) $(yassl_libs)
test_sslserver_SOURCES= test-sslserver.c $(yassl_dummy_link_fix)
test_sslserver_LDADD= @CLIENT_EXTRA_LDFLAGS@ ../dbug/libdbug.a libvio.a \
../mysys/libmysys.a ../strings/libmystrings.a \
- $(openssl_libs)
+ $(openssl_libs) $(yassl_libs)
test_sslclient_SOURCES= test-sslclient.c $(yassl_dummy_link_fix)
test_sslclient_LDADD= @CLIENT_EXTRA_LDFLAGS@ ../dbug/libdbug.a libvio.a \
../mysys/libmysys.a ../strings/libmystrings.a \
- $(openssl_libs)
+ $(openssl_libs) $(yassl_libs)
libvio_a_SOURCES= vio.c viosocket.c viossl.c viosslfactories.c
# Don't update the files from bitkeeper