summaryrefslogtreecommitdiff
path: root/unittest/Makefile.am
diff options
context:
space:
mode:
authorunknown <mkindahl@dl145h.mysql.com>2006-08-29 22:23:56 +0200
committerunknown <mkindahl@dl145h.mysql.com>2006-08-29 22:23:56 +0200
commit1b8dad2b58ba132a65d559f5756d06fe65fa929f (patch)
tree9f53514f88d028736962295c163eae9205eb284a /unittest/Makefile.am
parent92bbbaa4b07385cb689ac5e3d49207f810964846 (diff)
downloadmariadb-git-1b8dad2b58ba132a65d559f5756d06fe65fa929f.tar.gz
Various fixes to make MyTAP build on all platforms.
unittest/Makefile.am: Not installing unit.pl any more. Adding test-verbose target to see the TAP output (for debugging). unittest/mytap/tap.h: Including portability file. Whitespace changes. Code sample for BAIL_OUT() function.
Diffstat (limited to 'unittest/Makefile.am')
-rw-r--r--unittest/Makefile.am6
1 files changed, 2 insertions, 4 deletions
diff --git a/unittest/Makefile.am b/unittest/Makefile.am
index 6cca1165cfe..f2f7fc0bf7d 100644
--- a/unittest/Makefile.am
+++ b/unittest/Makefile.am
@@ -1,6 +1,5 @@
SUBDIRS = mytap . mysys examples
-noinst_SCRIPTS = unit
EXTRA_DIST = unit.pl
CLEANFILES = unit
@@ -9,6 +8,5 @@ unittests = mytap mysys
test:
perl unit.pl run $(unittests)
-unit: $(srcdir)/unit.pl
- install $(srcdir)/unit.pl $@
-
+test-verbose:
+ HARNESS_VERBOSE=1 perl unit.pl run $(unittests)