summaryrefslogtreecommitdiff
path: root/support-files/MacOSX/Makefile.am
diff options
context:
space:
mode:
authorunknown <lenz@mysql.com>2003-02-03 20:39:48 +0100
committerunknown <lenz@mysql.com>2003-02-03 20:39:48 +0100
commit46318870b042cfcd2449eef58c3a9519c00d409d (patch)
tree91b8500ad29cd9ee0cd23ebf67de2c56b7c16f39 /support-files/MacOSX/Makefile.am
parent39f46988e80efa85731b1127f20cac60cf17b4a3 (diff)
downloadmariadb-git-46318870b042cfcd2449eef58c3a9519c00d409d.tar.gz
- added support-files/MacOSX to include files specific for building
MacOSX packages using PackageMaker - renamed support-files/PKG -> support-files/SCO (PKG is used in MacOS X terminology as well) support-files/SCO/INSTALL.sh: mvdir support-files/SCO/compile.sh: mvdir support-files/SCO/doc.sh: mvdir support-files/SCO/mkpkg.sh: mvdir support-files/SCO/patch: mvdir support-files/SCO/pkginfo.ini: mvdir support-files/SCO/postinstall: mvdir support-files/SCO/preinstall: mvdir support-files/SCO/preremove: mvdir support-files/SCO/prototype.ini: mvdir support-files/SCO/version: mvdir support-files/MacOSX/make_mysql_pkg.pl: Rename: support-files/make_mysql_pkg.pl -> support-files/MacOSX/make_mysql_pkg.pl configure.in: - added support-files/MacOSX support-files/Makefile.am: - added MacOSX subdirectory
Diffstat (limited to 'support-files/MacOSX/Makefile.am')
-rw-r--r--support-files/MacOSX/Makefile.am37
1 files changed, 37 insertions, 0 deletions
diff --git a/support-files/MacOSX/Makefile.am b/support-files/MacOSX/Makefile.am
new file mode 100644
index 00000000000..0702d104e7e
--- /dev/null
+++ b/support-files/MacOSX/Makefile.am
@@ -0,0 +1,37 @@
+# Copyright (C) 2000 MySQL AB & MySQL Finland AB & TCX DataKonsult AB
+#
+# This library is free software; you can redistribute it and/or
+# modify it under the terms of the GNU Library General Public
+# License as published by the Free Software Foundation; either
+# version 2 of the License, or (at your option) any later version.
+#
+# This library is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# Library General Public License for more details.
+#
+# You should have received a copy of the GNU Library General Public
+# License along with this library; if not, write to the Free
+# Software Foundation, Inc., 59 Temple Place - Suite 330, Boston,
+# MA 02111-1307, USA
+
+## Process this file with automake to create Makefile.in
+
+EXTRA_DIST = Info.plist.sh Description.plist.sh
+
+pkgdata_DATA = Info.plist Description.plist
+
+CLEANFILES = Info.plist Description.plist
+
+SUFFIXES = .sh
+
+.sh:
+ @RM@ -f $@ $@-t
+ @SED@ \
+ -e 's!@''VERSION''@!@VERSION@!' \
+ -e 's!@''MYSQL_SERVER_SUFFIX''@!@MYSQL_SERVER_SUFFIX@!' \
+ $< > $@-t
+ @MV@ $@-t $@
+
+# Don't update the files from bitkeeper
+%::SCCS/s.%