summaryrefslogtreecommitdiff
path: root/sql/Makefile.am
diff options
context:
space:
mode:
authorunknown <msvensson@shellback.(none)>2006-09-18 21:11:34 +0200
committerunknown <msvensson@shellback.(none)>2006-09-18 21:11:34 +0200
commitb0b0b7c17907773ce6989a142c9af6197eb9cae7 (patch)
tree4ff3e7b9633ba95ee2c621cbf42e0106f61926be /sql/Makefile.am
parentbd8309cce6793352cebcf54459fa301eaab0b3b8 (diff)
downloadmariadb-git-b0b0b7c17907773ce6989a142c9af6197eb9cae7.tar.gz
BUG#19738 "make install" tries to build files that "make" should already have built
- Make built sources only depend on it's sources not the built tool extra/Makefile.am: The files built by "comp_err" should only depend on their sources not the tool comp_err The built sources should only be cleaned by "make distclean" sql/Makefile.am: The built file "lex_hash.h" should depend on it's sources
Diffstat (limited to 'sql/Makefile.am')
-rw-r--r--sql/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/sql/Makefile.am b/sql/Makefile.am
index 8428d6401b5..a106a2773f1 100644
--- a/sql/Makefile.am
+++ b/sql/Makefile.am
@@ -150,7 +150,11 @@ sql_yacc.o: sql_yacc.cc sql_yacc.h $(HEADERS)
@echo "If it fails, re-run configure with --with-low-memory"
$(CXXCOMPILE) $(LM_CFLAGS) -c $<
-lex_hash.h: gen_lex_hash$(EXEEXT)
+# This generates lex_hash.h
+# NOTE Built sources should depend on their sources not the tool
+# this avoid the rebuild of the built files in a source dist
+lex_hash.h: gen_lex_hash.cc lex.h
+ $(MAKE) $(AM_MAKEFLAGS) gen_lex_hash$(EXEEXT)
./gen_lex_hash$(EXEEXT) > $@
# For testing of udf_example.so