summaryrefslogtreecommitdiff
path: root/sql/CMakeLists.txt
diff options
context:
space:
mode:
authorIgor Babaev <igor@askmonty.org>2018-10-09 02:36:09 -0700
committerIgor Babaev <igor@askmonty.org>2019-02-06 17:02:44 -0800
commit16327fc2e76e9215059894b461e8aca7f989da00 (patch)
treed8189268b2af4eb6ac865e0d9c78cf2cd1eca587 /sql/CMakeLists.txt
parent171fbbb968ed52dc7e2bbd33a6f8f72bbc6f5e88 (diff)
downloadmariadb-git-16327fc2e76e9215059894b461e8aca7f989da00.tar.gz
MDEV-17096 Pushdown of simple derived tables to storage engines
MDEV-17631 select_handler for a full query pushdown Interfaces + Proof of Concept for federatedx with test cases. The interfaces have been developed for integration of ColumnStore engine.
Diffstat (limited to 'sql/CMakeLists.txt')
-rw-r--r--sql/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/sql/CMakeLists.txt b/sql/CMakeLists.txt
index 708c36a58b0..0c0851e5086 100644
--- a/sql/CMakeLists.txt
+++ b/sql/CMakeLists.txt
@@ -96,7 +96,7 @@ SET (SQL_SOURCE
sql_partition.cc sql_plugin.cc sql_prepare.cc sql_rename.cc
debug_sync.cc
sql_repl.cc sql_select.cc sql_show.cc sql_state.c
- group_by_handler.cc
+ group_by_handler.cc derived_handler.cc select_handler.cc
sql_statistics.cc sql_string.cc lex_string.h
sql_table.cc sql_test.cc sql_trigger.cc sql_udf.cc sql_union.cc
sql_update.cc sql_view.cc strfunc.cc table.cc thr_malloc.cc