summaryrefslogtreecommitdiff
path: root/sql/CMakeLists.txt
diff options
context:
space:
mode:
authorJustin Jagieniak <justin@jagieniak.net>2021-04-14 10:17:16 +0200
committerDaniel Black <daniel@mariadb.org>2021-04-15 10:07:50 +1000
commit1715fef107b2b0fab2b1e2dbac062b3ac7a9c6b2 (patch)
tree8ba25346b5a2da7330db85769fa2dc3aa844bfbf /sql/CMakeLists.txt
parentd1f2001ee6a184cf34005a1aa81c2179308cf537 (diff)
downloadmariadb-git-1715fef107b2b0fab2b1e2dbac062b3ac7a9c6b2.tar.gz
Fix cross-compile to consider CMAKE_CROSSCOMPILING_EMULATORbb-10.5-danielblack-pr1805-cross-compile
When CMAKE_CROSSCOMPILING_EMULATOR is defined, a cross-compile can be made, however with native (emulated) execution possible. This commit takes those points in the build system that execute built targets natively and allow these to be executed in a crosscompile if CMAKE_CROSSCOMPILING_EMULATOR is defined. Closes #1805
Diffstat (limited to 'sql/CMakeLists.txt')
-rw-r--r--sql/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/sql/CMakeLists.txt b/sql/CMakeLists.txt
index b9cd418f295..bff01ca817e 100644
--- a/sql/CMakeLists.txt
+++ b/sql/CMakeLists.txt
@@ -356,7 +356,7 @@ ELSE()
COMPILE_FLAGS "-p ORA")
ENDIF()
-IF(NOT CMAKE_CROSSCOMPILING)
+IF(NOT CMAKE_CROSSCOMPILING OR DEFINED CMAKE_CROSSCOMPILING_EMULATOR)
ADD_EXECUTABLE(gen_lex_token gen_lex_token.cc
${CMAKE_CURRENT_BINARY_DIR}/sql_yacc.hh)
ADD_EXECUTABLE(gen_lex_hash gen_lex_hash.cc)
@@ -406,7 +406,7 @@ ADD_CUSTOM_TARGET(distclean
)
# Install initial database (default on windows, optional target elsewhere)
-IF(TARGET mariadbd AND NOT CMAKE_CROSSCOMPILING)
+IF(TARGET mariadbd AND (NOT CMAKE_CROSSCOMPILING OR DEFINED CMAKE_CROSSCOMPILING_EMULATOR))
IF(GENERATOR_IS_MULTI_CONFIG)
SET (CONFIG_PARAM -DCONFIG=${CMAKE_CFG_INTDIR})
ENDIF()