summaryrefslogtreecommitdiff
path: root/scripts/Makefile.am
diff options
context:
space:
mode:
authorJoerg Bruehe <joerg@mysql.com>2009-09-08 15:35:01 +0200
committerJoerg Bruehe <joerg@mysql.com>2009-09-08 15:35:01 +0200
commit29d0fa12f7770b67c4df00ab1b4de13e0bfdf8bb (patch)
tree95662070b01e9dd3be33a0525885d24f1f3a9fce /scripts/Makefile.am
parent1459b65cf72b0bc92e51882035b0bcca9d3ebb9c (diff)
downloadmariadb-git-29d0fa12f7770b67c4df00ab1b4de13e0bfdf8bb.tar.gz
This is the 5.4 version of the fix for bug#47007
Unresolved reference to 'innodb_system_libs' in "mysql_config" In 5.4.2, we use InnoDB 1.0.4 which does file IO via separate threads, opposed to the use of asynchronous IO previously. So there is no InnoDB call to "aio_read()" which was searched in "librt", causing a "-lrt" value of "innodb_system_libs", that whole variable is gone. This fix was applied in the build of 5.4.2-beta. scripts/Makefile.am: There is no "innodb_system_libs" variable any more, so it cannot be replaced by its value. scripts/mysql_config.pl.in: InnoDB does not need any platform-specific libraries any more, "innodb_system_libs" may go. scripts/mysql_config.sh: InnoDB does not need any platform-specific libraries any more, "innodb_system_libs" may go.
Diffstat (limited to 'scripts/Makefile.am')
-rw-r--r--scripts/Makefile.am1
1 files changed, 0 insertions, 1 deletions
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
index e493c68827c..cd758370388 100644
--- a/scripts/Makefile.am
+++ b/scripts/Makefile.am
@@ -169,7 +169,6 @@ SUFFIXES = .sh
-e 's!@''ZLIB_LIBS''@!@ZLIB_LIBS@!' \
-e 's!@''LIBS''@!@LIBS@!' \
-e 's!@''WRAPLIBS''@!@WRAPLIBS@!' \
- -e 's!@''innodb_system_libs''@!@innodb_system_libs@!' \
-e 's!@''openssl_libs''@!@openssl_libs@!' \
-e 's!@''VERSION''@!@VERSION@!' \
-e 's!@''MYSQL_BASE_VERSION''@!@MYSQL_BASE_VERSION@!' \