summaryrefslogtreecommitdiff
path: root/scripts/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Black <daniel@mariadb.org>2021-03-30 14:57:58 +1100
committerDaniel Black <daniel@mariadb.org>2021-03-30 14:58:01 +1100
commit49ddfb63780c55b4133755c3479e13c7ea9a9d7b (patch)
treee58402afb99d2de66e4a43ce00167578ea3b64c6 /scripts/CMakeLists.txt
parent6ca07c21098a51c6b5a191e62fe23438abfec364 (diff)
downloadmariadb-git-49ddfb63780c55b4133755c3479e13c7ea9a9d7b.tar.gz
revert make_binary_distribution script creation
This was removed in 09202b2e6db0f2308c5c669322b057ac7f100378 however as Roel said, still in use. Adjusted to not create in WITHOUT_SERVER.
Diffstat (limited to 'scripts/CMakeLists.txt')
-rw-r--r--scripts/CMakeLists.txt10
1 files changed, 9 insertions, 1 deletions
diff --git a/scripts/CMakeLists.txt b/scripts/CMakeLists.txt
index 9ca806a797e..6408f1677dd 100644
--- a/scripts/CMakeLists.txt
+++ b/scripts/CMakeLists.txt
@@ -82,6 +82,14 @@ ADD_CUSTOM_TARGET(GenFixPrivs
DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/mysql_fix_privilege_tables_sql.c
)
+IF(UNIX AND NOT WITHOUT_SERVER)
+ FILE(WRITE ${CMAKE_CURRENT_BINARY_DIR}/make_binary_distribution
+ "cd ${CMAKE_BINARY_DIR} && '${CMAKE_CPACK_COMMAND}' -G TGZ --config CPackConfig.cmake\n" )
+ EXECUTE_PROCESS(
+ COMMAND chmod +x ${CMAKE_CURRENT_BINARY_DIR}/make_binary_distribution
+)
+ENDIF()
+
# Configure two scripts from one 'in' file.
# The maria_add_gis_sp.sql - to be sent to 'mysql' tool
# and the maria_add_gis_sp_bootstrap.sql, that can be sent to
@@ -397,4 +405,4 @@ IF(CMAKE_COMPILER_IS_GNUCXX AND CMAKE_CXX_FLAGS MATCHES "-static")
ENDIF()
ENDIF()
-ADD_SUBDIRECTORY(sys_schema) \ No newline at end of file
+ADD_SUBDIRECTORY(sys_schema)