summaryrefslogtreecommitdiff
path: root/mysys/Makefile.am
diff options
context:
space:
mode:
authorlenz@mysql.com <>2002-10-01 21:57:10 +0200
committerlenz@mysql.com <>2002-10-01 21:57:10 +0200
commit3cf7acb7567554a0bc7623d13172d47f9f0a0552 (patch)
tree1498636efd6a0835df79c54a9044e3f8215d61cb /mysys/Makefile.am
parent3aa161d240dccbf71fa3ab233bfe88025b8a0859 (diff)
downloadmariadb-git-3cf7acb7567554a0bc7623d13172d47f9f0a0552.tar.gz
- Applied required modifications for automake 1.5
- some additional small fixes - added "depcomp" for automake 1.5
Diffstat (limited to 'mysys/Makefile.am')
-rw-r--r--mysys/Makefile.am11
1 files changed, 1 insertions, 10 deletions
diff --git a/mysys/Makefile.am b/mysys/Makefile.am
index 4ff1b04fc79..c59d15d59f5 100644
--- a/mysys/Makefile.am
+++ b/mysys/Makefile.am
@@ -70,15 +70,6 @@ DEFS = -DDEFAULT_BASEDIR=\"$(prefix)\" \
libmysys_a_DEPENDENCIES= @THREAD_LOBJECTS@
-OMIT_DEPENDENCIES = pthread.h stdio.h __stdio.h stdlib.h __stdlib.h math.h\
- __math.h time.h __time.h unistd.h __unistd.h types.h \
- xtypes.h ac-types.h posix.h string.h __string.h \
- errno.h socket.h inet.h dirent.h netdb.h \
- cleanup.h cond.h debug_out.h fd.h kernel.h mutex.h \
- prio_queue.h pthread_attr.h pthread_once.h queue.h\
- sleep.h specific.h version.h pwd.h timers.h uio.h \
- cdefs.h machdep.h signal.h __signal.h util.h
-
# I hope this always does the right thing. Otherwise this is only test programs
FLAGS=$(DEFS) $(INCLUDES) $(CPPFLAGS) $(CFLAGS) @NOINST_LDFLAGS@
@@ -109,7 +100,7 @@ test_io_cache: mf_iocache.c $(LIBRARIES)
test_dir: test_dir.c $(LIBRARIES)
$(LINK) $(FLAGS) -DMAIN $(srcdir)/test_dir.c $(LDADD) $(LIBS)
-test_charset: test_charset.c $(LIBRARIES)
+test_charset$(EXEEXT): test_charset.c $(LIBRARIES)
$(LINK) $(FLAGS) -DMAIN $(srcdir)/test_charset.c $(LDADD) $(LIBS)
testhash: testhash.c $(LIBRARIES)