summaryrefslogtreecommitdiff
path: root/libmysqld/CMakeLists.txt
diff options
context:
space:
mode:
authorunknown <kent@mysql.com/kent-amd64.(none)>2007-08-02 15:37:33 +0200
committerunknown <kent@mysql.com/kent-amd64.(none)>2007-08-02 15:37:33 +0200
commit39371b1bcbb6bad75ecad0c044bf7de63a549741 (patch)
treebdf6feecf8d5d7a4329b50c709e550c9b8785c58 /libmysqld/CMakeLists.txt
parent88d913eb3e236601ff4bce115d45f2ce70c62cb0 (diff)
downloadmariadb-git-39371b1bcbb6bad75ecad0c044bf7de63a549741.tar.gz
Makefile.am:
Add CMakeLists.txt to source distribution CMakeLists.txt: Added missing '${MYSQLD_EXE_SUFFIX}' to "mysqld" targets new in 5.1 Manual merge from 5.0 (bug#30118) CMakeLists.txt, mysqlbinlog.cc, lib_sql.cc: No need to test on USING_CMAKE, it is the only Windows build client/mysqlbinlog.cc: No need to test on USING_CMAKE, it is the only Windows build libmysqld/CMakeLists.txt: No need to test on USING_CMAKE, it is the only Windows build libmysqld/lib_sql.cc: No need to test on USING_CMAKE, it is the only Windows build libmysqld/Makefile.am: Add CMakeLists.txt to source distribution libmysqld/examples/Makefile.am: Add CMakeLists.txt to source distribution sql/CMakeLists.txt: Added missing '${MYSQLD_EXE_SUFFIX}' to "mysqld" targets new in 5.1 client/CMakeLists.txt: Manual merge from 5.0 (bug#30118) libmysql/CMakeLists.txt: Manual merge from 5.0 (bug#30118) mysys/CMakeLists.txt: Manual merge from 5.0 (bug#30118) zlib/CMakeLists.txt: Manual merge from 5.0 (bug#30118)
Diffstat (limited to 'libmysqld/CMakeLists.txt')
-rw-r--r--libmysqld/CMakeLists.txt4
1 files changed, 0 insertions, 4 deletions
diff --git a/libmysqld/CMakeLists.txt b/libmysqld/CMakeLists.txt
index dd42bafcfe0..45a298b2efe 100644
--- a/libmysqld/CMakeLists.txt
+++ b/libmysqld/CMakeLists.txt
@@ -20,10 +20,6 @@ SET(CMAKE_C_FLAGS_DEBUG "${CMAKE_C_FLAGS_DEBUG} -DSAFEMALLOC -DSAFE_MUTEX")
# storage does not work properly in DLLs.
ADD_DEFINITIONS(-DUSE_TLS -DMYSQL_SERVER)
-# The old Windows build method used renamed (.cc -> .cpp) source files, fails
-# in #include in lib_sql.cc. So disable that using the USING_CMAKE define.
-ADD_DEFINITIONS(-DUSING_CMAKE)
-
INCLUDE_DIRECTORIES(${CMAKE_SOURCE_DIR}/include
${CMAKE_SOURCE_DIR}/libmysqld
${CMAKE_SOURCE_DIR}/libmysql