summaryrefslogtreecommitdiff
path: root/include/Makefile.am
diff options
context:
space:
mode:
authorMichael Widenius <monty@askmonty.org>2010-05-26 22:27:01 +0300
committerMichael Widenius <monty@askmonty.org>2010-05-26 22:27:01 +0300
commit9e23495b1dc988526776768f50a30f647d793d14 (patch)
tree8f5166007a2603ef6cb45ddd08beca6b6da3a3fd /include/Makefile.am
parent2d43ff67ddab70e6fb89682e201cb788c845e71e (diff)
downloadmariadb-git-9e23495b1dc988526776768f50a30f647d793d14.tar.gz
Added macros to inform valgrind that memory is uninitialized
include/Makefile.am: Make my_valgrind.h global (as it's used by my_global.h) include/my_global.h: Include my_valgrind.h include/my_sys.h: TRASH() moved to my_valgrind.h include/my_valgrind.h: Add VALGRIND defines to mark memory mysys/my_alloc.c: Mark internal freed memory as undefined
Diffstat (limited to 'include/Makefile.am')
-rw-r--r--include/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/Makefile.am b/include/Makefile.am
index 516fdeee392..4d932d3159c 100644
--- a/include/Makefile.am
+++ b/include/Makefile.am
@@ -23,7 +23,7 @@ HEADERS_ABI = mysql.h mysql_com.h mysql_time.h \
pkginclude_HEADERS = $(HEADERS_ABI) my_dbug.h m_string.h my_sys.h \
my_xml.h mysql_embed.h \
my_pthread.h my_no_pthread.h \
- decimal.h errmsg.h my_global.h my_net.h \
+ decimal.h errmsg.h my_global.h my_valgrind.h my_net.h \
my_getopt.h sslopt-longopts.h my_dir.h \
sslopt-vars.h sslopt-case.h sql_common.h keycache.h \
m_ctype.h my_attribute.h $(HEADERS_GEN_CONFIGURE) \