summaryrefslogtreecommitdiff
path: root/include/Makefile.am
diff options
context:
space:
mode:
authorMySQL Build Team <build@mysql.com>2009-04-05 22:18:21 +0200
committerMySQL Build Team <build@mysql.com>2009-04-05 22:18:21 +0200
commite4c94f0f2c825ba0f324c5c874e11dc902104be4 (patch)
treea22b2905fc8722596781332741434450056d4853 /include/Makefile.am
parente3550f5120104238b35d5f215d4065c533c61029 (diff)
downloadmariadb-git-e4c94f0f2c825ba0f324c5c874e11dc902104be4.tar.gz
Ensure that all dtrace files are properly removed during make clean
Diffstat (limited to 'include/Makefile.am')
-rw-r--r--include/Makefile.am7
1 files changed, 3 insertions, 4 deletions
diff --git a/include/Makefile.am b/include/Makefile.am
index dee012741a7..214ef8862e9 100644
--- a/include/Makefile.am
+++ b/include/Makefile.am
@@ -15,7 +15,7 @@
# Software Foundation, Inc., 59 Temple Place - Suite 330, Boston,
# MA 02111-1307, USA
-BUILT_SOURCES = $(HEADERS_GEN_MAKE) link_sources
+BUILT_SOURCES = $(HEADERS_GEN_MAKE) link_sources probes_mysql_nodtrace.h
HEADERS_GEN_CONFIGURE = mysql_version.h
HEADERS_GEN_MAKE = my_config.h
HEADERS_ABI = mysql.h mysql_com.h mysql_time.h \
@@ -40,8 +40,7 @@ noinst_HEADERS = config-win.h config-netware.h my_bit.h \
my_vle.h my_user.h my_atomic.h atomic/nolock.h \
atomic/rwlock.h atomic/x86-gcc.h atomic/x86-msvc.h \
atomic/solaris.h \
- atomic/gcc_builtins.h my_libwrap.h my_stacktrace.h \
- probes_mysql.h probes_mysql_nodtrace.h
+ atomic/gcc_builtins.h my_libwrap.h my_stacktrace.h
EXTRA_DIST = mysql.h.pp mysql/plugin.h.pp probes_mysql.d.base
@@ -77,7 +76,7 @@ probes_mysql.d:
DTRACEPROVIDER = probes_mysql.d
if HAVE_DTRACE
BUILT_SOURCES += probes_mysql_dtrace.h
-CLEANFILES += probes_mysql_dtrace.h
+CLEANFILES += $(DTRACEPROVIDER)
# Fake for creating the probes file. If we are building a separate directory
# then we copy the probes from the source location and use that