summaryrefslogtreecommitdiff
path: root/include/Makefile.am
diff options
context:
space:
mode:
authorChad MILLER <chad@mysql.com>2009-03-19 09:37:30 -0400
committerChad MILLER <chad@mysql.com>2009-03-19 09:37:30 -0400
commit9bdcb6ba6ebbb5747c7be7d8c9620574c74601d6 (patch)
tree3b67b277a49cbc606615070f86bc4a5493cab977 /include/Makefile.am
parent1fd4ed8ed84d88a97438004b71e37a0d82392bc3 (diff)
downloadmariadb-git-9bdcb6ba6ebbb5747c7be7d8c9620574c74601d6.tar.gz
Copy include/config.h to include/my_config.h at configure-time. Also,
continue to update it at make-time. One shouldn't need to run "make" on server source to get the stuff we say plugins should use.
Diffstat (limited to 'include/Makefile.am')
-rw-r--r--include/Makefile.am8
1 files changed, 3 insertions, 5 deletions
diff --git a/include/Makefile.am b/include/Makefile.am
index 64f73af8606..de13a418c0c 100644
--- a/include/Makefile.am
+++ b/include/Makefile.am
@@ -15,9 +15,8 @@
# Software Foundation, Inc., 59 Temple Place - Suite 330, Boston,
# MA 02111-1307, USA
-BUILT_SOURCES = $(HEADERS_GEN_MAKE) link_sources
-HEADERS_GEN_CONFIGURE = mysql_version.h
-HEADERS_GEN_MAKE = my_config.h
+BUILT_SOURCES = link_sources
+HEADERS_GEN_CONFIGURE = mysql_version.h my_config.h
HEADERS_ABI = mysql.h mysql_com.h mysql_time.h \
my_list.h my_alloc.h typelib.h mysql/plugin.h
pkginclude_HEADERS = $(HEADERS_ABI) my_dbug.h m_string.h my_sys.h \
@@ -26,8 +25,7 @@ pkginclude_HEADERS = $(HEADERS_ABI) my_dbug.h m_string.h my_sys.h \
decimal.h errmsg.h my_global.h my_net.h \
my_getopt.h sslopt-longopts.h my_dir.h \
sslopt-vars.h sslopt-case.h sql_common.h keycache.h \
- m_ctype.h my_attribute.h $(HEADERS_GEN_CONFIGURE) \
- $(HEADERS_GEN_MAKE)
+ m_ctype.h my_attribute.h $(HEADERS_GEN_CONFIGURE)
noinst_HEADERS = config-win.h config-netware.h my_bit.h \
heap.h my_bitmap.h my_uctype.h \