summaryrefslogtreecommitdiff
path: root/include/Makefile.am
diff options
context:
space:
mode:
authorunknown <msvensson@pilot.(none)>2007-08-27 13:55:45 +0200
committerunknown <msvensson@pilot.(none)>2007-08-27 13:55:45 +0200
commit1413fdb24e0acc72299e95daff983364e17c3796 (patch)
treea040a86b2e84fe325a1fb841407f372df1f377e5 /include/Makefile.am
parent88c778127e04d6fcae19f6b79376e9d3ea336515 (diff)
downloadmariadb-git-1413fdb24e0acc72299e95daff983364e17c3796.tar.gz
Enable abi_check for 5.1
- Run icheck on all files in HEADERS_ABI list - Update reference include/Makefile.am: Enable abi_check for external API header files include/mysql_h.ic: Update abi_check reference
Diffstat (limited to 'include/Makefile.am')
-rw-r--r--include/Makefile.am12
1 files changed, 5 insertions, 7 deletions
diff --git a/include/Makefile.am b/include/Makefile.am
index fe54a7e35e0..2775932f46d 100644
--- a/include/Makefile.am
+++ b/include/Makefile.am
@@ -15,18 +15,17 @@
# Software Foundation, Inc., 59 Temple Place - Suite 330, Boston,
# MA 02111-1307, USA
-# FIXME 'abi_check' should be in BUILT_SOURCES, disabled for now
-BUILT_SOURCES = $(HEADERS_GEN) link_sources
+BUILT_SOURCES = $(HEADERS_GEN) link_sources abi_check
HEADERS_GEN = mysql_version.h my_config.h
HEADERS_ABI = mysql.h mysql_com.h mysql_time.h \
- my_list.h my_alloc.h typelib.h
+ my_list.h my_alloc.h typelib.h mysql/plugin.h
pkginclude_HEADERS = $(HEADERS_ABI) my_dbug.h m_string.h my_sys.h \
my_xml.h mysql_embed.h \
my_pthread.h my_no_pthread.h \
decimal.h errmsg.h my_global.h my_net.h \
my_getopt.h sslopt-longopts.h my_dir.h \
sslopt-vars.h sslopt-case.h sql_common.h keycache.h \
- m_ctype.h mysql/plugin.h my_attribute.h $(HEADERS_GEN)
+ m_ctype.h my_attribute.h $(HEADERS_GEN)
noinst_HEADERS = config-win.h config-netware.h \
heap.h my_bitmap.h my_uctype.h \
myisam.h myisampack.h myisammrg.h ft_global.h\
@@ -72,9 +71,8 @@ dist-hook:
abi_check: $(HEADERS_ABI) mysql_version.h mysql_h.ic
@set -ex; \
if [ @ICHECK@ != no ] ; then \
- @ICHECK@ --canonify --skip-from-re /usr/ -o $@.ic mysql.h; \
- @ICHECK@ --compare mysql_h.ic $@.ic; \
- $(RM) -f $@.ic; \
+ @ICHECK@ --canonify --skip-from-re /usr/ -o $@ $(HEADERS_ABI); \
+ @ICHECK@ --compare mysql_h.ic $@; \
fi; \
touch abi_check;